ERROR: APACHE_PID_FILE needs to be defined in /etc/apache2/envvars

Publié le par maryytech.over-blog.com

Vous avez fait évoluer votre (vieux) serveur de Debian Etch vers Debian Lenny. C'est bien ! Mais vous obtenez le message d'erreur :

 

ERROR: APACHE_PID_FILE needs to be defined in /etc/apache2/envvars

 

Du coup, tout est planté, c'est la cata. Ben oui ! S'il n'y a que cette erreur, pas de panique, voici comment s'en sortir.

 

Il suffit de faire la manipulation suivante :

 

cp /etc/apache2/envvars.dpkg-dist /etc/apache2/envvars

 

Si le fichier envvars.dpkg-dist n'existe pas alors créez ou éditez le fichier /etc/apache2/envvars et collez-y les lignes suivantes :

 

export APACHE_RUN_USER=www-data
export APACHE_RUN_GROUP=www-data
export APACHE_PID_FILE=/var/run/apache2.pid

 

Si vous utilisez un autre utilisateur que www-data, pensez à le remplacer par le bon nom d'utilisateur.

 

On redémarre apache et ça devrait être bien mieux !

Publié dans Linux

Commenter cet article